Re: Naming conventions for private virtual methods
On 2/14/2014 11:27 AM, Daniel wrote:
I know, nobody likes this kind of question, but there aren't many
questions these days, so ...
Consider a case of private virtual inheritance where the motivation
is
There is no private virtual inheritance in your post, just so we talk
about the same thing, a private virtual inheritance is this relationship
between classes A and B:
class A { ... };
class B : virtual A { ... };
to have overloading on the preferred method name "value".
class base
{
public:
void value(int val)
{
// calls value_
}
void value(long val)
{
// calls value_
}
void value(long long val)
{
// calls value_
}
private:
virtual void value_(long long val) = 0;
};
class derived : public base
{
private:
// implements value_
};
Can anyone suggest a reasonable naming convention for the overridable
private method value_? I've seen variants of "doValue",
"value_long_long", and "value_event". Any commonly used conventions?
From the implementation 'value' here is a "setter", so it might make
sense to indicate that.
Another argument is that the overloaded function shall be specific to
each class deriving from 'base', so it might make sense to add
"specific" to it (either as a suffix or as a prefix).
And of course I admit that I am not aware of any convention you're
alluding to in your message. If there exists something of that sort, I
have never come across it, or cannot recall such an occurrence.
V
--
I do not respond to top-posted replies, please don't ask