Re: inheriting from std::vector bad practice?
* Steve Chow:
Originally I had a bunch of related functions that all took a vector
of Point2D as their argument.
Point2D findGreatestDistance(std::vector<Point2D>& points);
However, this didn't strike me as a very C++/OO way to do things, so I
found a solution I was happy with in:
class Path : public std::vector<Point2D>
{
public:
Path();
~Path();
Point2D findGreatestDistance();
/* related functions */
};
And it works, at least as far as I can tell. Yet it's been received by
people more knowledgeable than me as disgusting and wrong, without
explaining why. Is there a better way I should be doing this?
Yes. In terms of knowledge distribution you have ensured that the knowledge
required to do something (findGreatestDistance) is there. But in doing so you
have enabled both inadvertent and intentional abuse of knowledge, like posting a
recipe for creating a simple biological weapon-of-mass-destruction on the net;
you have forgotten to /limit/ the access to those in need to know.
Someone suggested moving findGreatestDistance into Point2D (struct
with x,y and overload ==) but I don't see how that's possible because
it'd only be able to look at itself.
Yes, that sounds like a silly suggestion.
Instead, replace inheritance of std::vector<Point2D> with a private member.
Also, I'd rename 'findGreatestDistance' to just 'greatestDistance' (like,
although not in your code, I'd also rename 'calculateSin' to just 'sin', and so
on), and I'd make a type distinction between points and vectors, but as opposed
to getting rid of that inheritance this is to some degreee personal preference.
Cheers & hth.,
- Alf