Re: Help with naming convention requested
* James Kanze:
On Jun 12, 5:06 pm, "Alf P. Steinbach" <al...@start.no> wrote:
* James Kanze:
I have a particular case where I'm having a problem deciding on
a good naming convention. Basically, I have several classes
which are split in two: there is a base class, which is a POD
(designed to support static initialization) and has only const
functions; and a derived class, which has the usual
constructors, and various non-const functions. A good example
of this is SetOfCharacter for UTF8: the base class has functions
like:
template< typename ForwardIterator >
bool isSet( ForwardIterator begin,
ForwardIterator end ) const ;
(where the iterators designate a sequence of UTF-8 characters,
and the function returns true for the first character in the
sequence), and a function:
void dumpAsCpp( std::ostream& dest ) const ;
which outputs a declaration of the class with algomerate
initialization (with all of the necessary sub-tables in
anonymous namespace). The derived class has all of the
classical constructors, and the non-const operators, which build
and modify the data structure. The separation is essential
because it allows such objects to be statically initialized and
thus avoids order of initialization problems.
Consider using singletons, or completely rethinking that design.
How can singletons help, given that I have many, many instances
of the type?
Given that you really need to have a great many separately named instances, you
can still use the main singleton implementation ideas to avoid order of
initialization problems; of course they'll not be singletons then but so what. :-)
Instad of writing directly, at file scope,
Gnurkle o1;
Gnurkle o2( &o1 );
you'd then make use of e.g. Meyer's singleton implementation technique and write
Gnurkle& o1Ref() { static Gnurkle o1; return o1; }
Gnurkle& o2Ref() { static Gnurkle o2( &o1Ref() ); return o2; }
which can easily be wrapped in a macro,
#define MAKE_REF_FUNC( name, args ) \
Gnurkle& name ## Ref() { static Gnurkle name = Gnurkle args; return name; }
and then write
MAKE_REF_FUNC( o1,() )
MAKE_REF_FUNC( o2,( &o1Ref() ) )
and with this there's no need to make Gnurkle a POD, plus, you're practically
guaranteed avoiding any static initialization order fiasco.
Names above can, of course, be improved... :-)
[snip]
I'm working in C++. In
the first version, I didn't use static data, and the program
took close to a half an hour to start. For a program that's
typically invoked just to process a few lines, that's simply not
acceptable.
Assuming you're now down to something more reasonable, like 0.1 seconds, that's
a factor of 18 000 and sounds like a bug, not the result of added function call
overhead.
[snip]
Since you're aiming for POD'ness, how about including "POD" in
the name?
Because the POD'ness is a means to an end, and not a goal in
itself. And because it's the base class, and for most client
code, it's the class they should be using. In many ways, I
really think that SetOfCharacter should be the name of the base
class, with maybe MutableSetOfCharacter the derived class.
Ah, well, I disagree, for two reasons. First, if my window abstraction is a
means to earn money in order to not suffer from lacking such, and thus be happy,
well I don't name it BeHappy. Even if that's the final end it is a means for.
:-) And second, I like names to be such that when I see the name I get a correct
impression, or at least not a misleading one, about what that name names. And
what you have been talking most about for this class is POD'ness, that's
apparently the most important aspect and the reason the class exists at all, so
if I were to choose a name I'd include that most important aspect, not hide it!
Cheers, & hth.,
- Alf
--
A: Because it messes up the order in which people normally read text.
Q: Why is it such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail?