Re: How do I paint on an existing Panel?
Neil Morris wrote:
I had the same problem! my solution is as follows
/*
* To change this template, choose Tools | Templates
* and open the template in the editor.
*/
package imagelibrary;
//~--- JDK imports
------------------------------------------------------------
import java.awt.Dimension;
import java.awt.Graphics;
import java.awt.LayoutManager;
import java.awt.image.BufferedImage;
import java.io.File;
import java.io.FileInputStream;
import java.io.IOException;
import javax.imageio.ImageIO;
import java.io.InputStream;
import javax.swing.JPanel;
/**
*
* @author NeilLewisMorris
*/
public class ImagePanel extends JPanel {
private BufferedImage Bimage = null;
Please follow the Java naming conventions ('bImage' or 'bimage', not 'Bimage').
It is not necessary to redundantly initialize member variables to 'null' (or
the primitive defaults if the variable is primitive). This just has the result
of setting the variable to 'null' twice.
private File imageFile = null;
private InputStream imageInputStream = null;
private Dimension size;
private double panelWidth;
private double panelHeight;
private double BimageWidth;
.... naming conventions ...
private double BimageHeight;
private double scaledWidth;
private double scaledHeight;
'scaledWidth' and 'scaledHeight' should not be member variables, based on what
you show in your code. They have nothing to do with instance state and should
be relegated to local variables. Likewise with 'scaled' and several others. You
need to analyze your scope strategy thoroughly; it isn't right.
private double scaled;
private double startX = 0;
While it's not necessary to set these values to 0 (actually 0.0) explicitly,
some think that there's a documentary advantage to doing so. I don't see it,
but that's me.
private double startY = 0;
public ImagePanel() {
super();
This call to 'super()' is not needed and is potentially distracting.
}
public ImagePanel(LayoutManager layout) {
super(layout);
}
@Override
public void paintComponent(Graphics g) {
super.paintComponent(g);
if (Bimage != null) {
BimageWidth = Bimage.getWidth();
BimageHeight = Bimage.getHeight();
panelWidth = getWidth();
panelHeight = getHeight();
scaledWidth = panelWidth / BimageWidth;
scaledHeight = panelHeight / BimageHeight;
if (scaledWidth > scaledHeight) {
scaled = scaledHeight;
} else {
scaled = scaledWidth;
}
scaledWidth = scaled * BimageWidth;
scaledHeight = scaled * BimageHeight;
startX = (panelWidth - scaledWidth) / 2;
startY = (panelHeight - scaledHeight) / 2;
} else {
scaledWidth = 0;
scaledHeight = 0;
}
if (Bimage != null) {
g.drawImage(Bimage, (int)startX, (int)startY, (int)
scaledWidth, (int) scaledHeight, this);
}
}
public File getImageFile() {
return imageFile;
}
public boolean setImageFile(File file) throws IOException {
imageFile = file;
return setImageInputStream(new FileInputStream(imageFile));
}
public boolean setImageInputStream(InputStream inputstream) {
imageInputStream = inputstream;
try {
Bimage = ImageIO.read(imageInputStream);
} catch (IOException e) {
return false;
Logging?
}
revalidate();
repaint();
This doesn't seem the right place to 'revalidate()', much less 'repaint()'.
Also, it might be a good idea to move the file action off the EDT.
return true;
}
}
Review best practices on variable scoping and study the Java coding
conventions. Flouting them is jarring to code reviewers and increases the risk
of bugs.
--
Lew