Re: How can you make idle processors pick up java work?
To: qwertmonkey
From: Daniel Pitts <newsgroup.nospam@virtualinfinity.net>
On 7/31/12 7:46 PM, qwertmonkey@syberianoutpost.ru wrote:
just in case someone ponders over the same. At the end of the day there is
no speed improvement whatsoever compared to doing the char reading into a
buffer and parsing out the sentences yourself
~
the code below does the same thing
~
BfR = Files.newBufferedReader(IFlPth, Charset.forName("UTF-8"));
// __
aSx = BfR.readLine();
while(aSx != null){
iSL = aSx.length();
for(int k = 0; (k < iSL); ++k){
iKdPnt = aSx.codePointAt(k);
++lTtlKdPnts;
}
++lLns;
iTtlRdByts += iSL;
aSx = BfR.readLine();
}// (iRdByts > -1)
// __
BfR.close();
~
lbrtchx
You're code uses such terrible naming conventions that it is impossible to read
and understand. "BfR" should be something like "reader" or "bufferedReader".
aSx? Should that be "line"?
k? who uses "k" as a for loop index? Unless you're doing a three-level deep
Dynamic Programming algorithm.
It also appears that you're trying to use some sort of Hungarian notation, and
doing it contra the original intent: See
<http://www.joelonsoftware.com/articles/Wrong.html>
BfR.close() should be in a finally block.
You also aren't declaring any variable here, so we have no idea what types they
are. You should declare variables as closely to the first use as is possible.
Also, it looks like you're trying to micro-optimize this code which reads one
line at a time. What is the point of doing iKdPnt = aSx.codePointAt(k), when
you don't actually use that variable in the for loop?
What is it exactly that you're trying to do? I mean, what's your end goal, not
what the means you've chosen for that end.
--- BBBS/Li6 v4.10 Dada-1
* Origin: Prism bbs (1:261/38)
--- Synchronet 3.16a-Win32 NewsLink 1.98
Time Warp of the Future BBS - telnet://time.synchro.net:24