Re: attack of silly coding standard?
On Dec 7, 1:54 am, Ian Collins <ian-n...@hotmail.com> wrote:
On 12/ 7/10 02:32 PM, Keith H Duggar wrote:
On Dec 6, 8:04 pm, Leigh Johnston<le...@i42.co.uk> wrote:
First random choice of a *real world* function of mine:
plugins::entry_list::iterator plugins::find(const plugin& aEntry)
{
lib::lock lock(*this);
for (entry_list::iterator i = iEntries.begin(); i != iEntries.end(); ++i)
if (i->path() == aEntry.path())
return i;
return iEntries.end();
}
Anyhow, your example is fine as either SEME or SESE. I certainly would
not reject it in a review (though I wonder question a design that does
not allow easy use of STL find).
That's more or less my position as well. I might also question
why the added complexity? Why not use the canonical form?
That said I would have coded the loop the same way some STL
implementations do:
plugins::entry_list::iterator plugins::find(const plugin& aEntry)
{
lib::lock lock(*this) ;
entry_list::iterator i = iEntries.begin() ;
entry_list::iterator const e = iEntries.end() ;
while ( i != e&& i->path() != aEntry.path() ) ++i ;
return i ;
}
Do you really find that clearer?
If he'd put the statement controled by the while on a separate
line, it would be significantly clearer. If for no other reason
that it makes the loop invariant explicit.
At least with Leigh's version it is immediately clear to the
reader what gets returned if a match isn't found.
At least with Leigh's version, you have to do a little bit of
additional analysis to prove progress in the loop, and to prove
that the loop actually terminates. For such simple cases, the
difference is marginal (unless, as I mentionned elsewhere,
you've automated some of the verification).
Which by the way is likely to be faster than your version (because of
the cached end iterator and removal of the unlikely event == from the
branch condition replacing it with the more likely event !=).
end() would very likely be optimised to a constant.
Not according to the measurements I've made. But IMHO, that's
an irrelevant point: I'd write "while ( i != iEntries.end()
...." myself. (Until the profiler said I had to change it, of
course.)
--
James Kanze